Triumph Bobber Forum banner
1 - 20 of 20 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
Hey all, so I had a BC x-pipe installed on my bobber yesterday. And the ride home left me thinking what the F_ck have I done.
It sounds a little better, but I think there is less torque and some popping on decel / downshift, It has the Vance and hines pipes on it.
My main concern is that I am doing something that will hurt the engine?
The mechanic SAID they did the 12 minute re tune, and ran it on their Dyno, and it came up as running a little on the lean side.
I am not 100% convinced they did the auto tune, or at least correctly... so I re-did it this am and am about to take it out for a spin.
If the issue is still there I am considering getting the cat put back on. :-(
But if anyone has had this issue I am happy to hear suggestions. Thanks
the jury is still out...
 

·
Registered
Joined
·
248 Posts
I de catted a couple of years ago. Big improvement. I did the 12 minute tune straight after, then went out for a spin. For me the throttle felt much more responsive, especially at low speed/launch. It does pop though from open throttle to shut down, but I love that. If you don't like the popping, a booster plug should solve the problem, but it's going to eat into your tank range.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #3 ·
Thanks...
Just got back from a ride... its WAY better after a properly done 12 min tune... The better sound is there, the torque is back and I had to work hard to try and get even a small amount of pop on throttle shut done. I can live with it. I'll give it a week and check the plugs for any issues but I think it's way better, ( less lean) than pre 12 min tune.
And LLR-71 thanks for the note re the booster and tank range, that was one of my concerns re the X-pipe to begin with. I get already enough grief from riding buddies about my tiny tank. :)
 

·
Registered
Joined
·
1,711 Posts
Hey all, so I had a BC x-pipe installed on my bobber yesterday. And the ride home left me thinking what the F_ck have I done.
It sounds a little better, but I think there is less torque and some popping on decel / downshift, It has the Vance and hines pipes on it.
My main concern is that I am doing something that will hurt the engine?
The mechanic SAID they did the 12 minute re tune, and ran it on their Dyno, and it came up as running a little on the lean side.
I am not 100% convinced they did the auto tune, or at least correctly... so I re-did it this am and am about to take it out for a spin.
If the issue is still there I am considering getting the cat put back on. :-(
But if anyone has had this issue I am happy to hear suggestions. Thanks
the jury is still out...
I have v and h exhaust and x pipe.

The Quick cheapish fix is do a 12 minute tune, this does improve things with this set up. Then chuck a booster plug on to richen it up a bit.
Works a charm and smoothes it all out
 

·
Registered
Joined
·
1,711 Posts
Thanks...
Just got back from a ride... its WAY better after a properly done 12 min tune... The better sound is there, the torque is back and I had to work hard to try and get even a small amount of pop on throttle shut done. I can live with it. I'll give it a week and check the plugs for any issues but I think it's way better, ( less lean) than pre 12 min tune.
And LLR-71 thanks for the note re the booster and tank range, that was one of my concerns re the X-pipe to begin with. I get already enough grief from riding buddies about my tiny tank. :)
Was one of my worries but,
The booster plug fuel difference is negligible in real time. Hardly notice. Defo NOT the differnce of not stopping until the next gas station. You can burn far more fuel with your right wrist.

I rode with another bobber with plug fitted and not fitted to both bikes equally. Both with V&H. There was a bigger differnce in range between the 2 bikes than 1 bike with or without the booster plug
 

·
Registered
2018 Speedmaster
Joined
·
69 Posts
I have the same Meerkat and Vance and Hines combination on my 18 Speedmaster, along with the DNK tune, and the high flow DNA replacement air filters.
As I've ridden several times since install, I think the bikes air/fuel system has adjusted to the combo. Still loud with a lot of throttle, great throttle response, smooth at low speed with steady throttle, not too much popping on decel, none when I pull in the clutch.
Great power and acceleration as compared to before I added everything. Very happy.
50195
 

·
Registered
Joined
·
60 Posts
I just picked up my 2022 Bobber last Thursday. I have the Motone x pipe coming. Dealer says the '22 is now a self learn and it should be a bolt on an go. Looking for a bit more noise from the bike. During breaking in I'd like to hear the engine a bit more instead of eyeing the tach readout all the time.
 

·
Registered
Joined
·
1,711 Posts
Thanks all for the replies, After another couple rides I am convinced the me the mechanic didn't do the auto tune right. After doing it correctly, thanks to a search to this site, things are WAY better. Thanks again
If you noticed the differnce after the 12 minuter. The differnce the BP will improve it now is twice as much again from where you are now after the 12 minute tune. Obviously there is the ecu option.

I bought the BP plug from a member on here. He upgraded to the power commander. Said it was better than the BP but not really enough improvement to warrent the extra cost. Depends what you want/ ease of fit /budget etc.
 

·
Registered
2018 triumph bonneville bobber black
Joined
·
11 Posts
Glad we are all enjoying our bikes.. I have the Lossa engineering X-Pipe and recently replaced my Vance and Hines with Cone engineering Martini exhaust.. in my opinion it's a much better sound and looks more old school for my style. I originally did the 12 minute procedure but realized it wasn't long enough since the weather has been kinda chilly and the fan never came on. I redid it until the fan came on , normal operating temp, although it took almost 20 minutes. Wow, what a difference. Anybody who didn't feel the difference May be because they didn't let it reach proper temp to force the ECU to learn the proper air fuel mixture. Try it until the fan comes on, let it cool a bit then take her on a spin. You will definitely feel and hear the difference.. ride safe my friends..
Oh, here is a link to a video of my exhaust on YouTube, let me know if you like it.

 

Attachments

·
Registered
Joined
·
32 Posts
Thanks...
Just got back from a ride... its WAY better after a properly done 12 min tune... The better sound is there, the torque is back and I had to work hard to try and get even a small amount of pop on throttle shut done. I can live with it. I'll give it a week and check the plugs for any issues but I think it's way better, ( less lean) than pre 12 min tune.
And LLR-71 thanks for the note re the booster and tank range, that was one of my concerns re the X-pipe to begin with. I get already enough grief from riding buddies about my tiny tank. :)
Fitting a larger Speedmaster or 2021 Bobber tank and ditching the rubbish monoshock are the 2 best mods to a stock bobber, then the seat it you have a personal rear end requirement but I’d say there isn’t much gain swapping exhausts given the costs🤔
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #19 ·
Fitting a larger Speedmaster or 2021 Bobber tank and ditching the rubbish monoshock are the 2 best mods to a stock bobber, then the seat it you have a personal rear end requirement but I’d say there isn’t much gain swapping exhausts given the costs🤔
Sounds like we are on similar pages. I’ve got a wilbers on order, front is next.:), and have been loving my Corbin, best change I’ve done, that with the forward controls, Has let me stay on the bike for 10 rides more than once.
 

·
Registered
Joined
·
1 Posts
Hi all,
Need your help and experience on this one.
I installed an x-pipe and a pair of baak mufflers on my bobber black.
All is ok but for some reason when I decel , beside the popping I am hearing an anoying sound from the engine. This sound is from the extra fuel that is not burnt in the xpipe. It sounds like a tik tik sound.
I removed the xpipe and fitted the cat again and the sound does not exist any more.
Does anyone have any idea how i can solve this anoying issue?

Thanks
 
1 - 20 of 20 Posts
Top