Triumph Bobber Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
hi all,
have had an intermittent "failure" in which the mc (2017 bobber) stalls when clutch is in, bike put into first and about to release clutch.
im not a novice (riding since 1986) and this isnt a newbie stall...it feels like the rpms suddenly drop.
this has happened 4x in about 4k miles...rare, but has happened at very inopportune times
has anyone else experienced this?
any fix?
 

·
Registered
Joined
·
137 Posts
hi all,
have had an intermittent "failure" in which the mc (2017 bobber) stalls when clutch is in, bike put into first and about to release clutch.
im not a novice (riding since 1986) and this isnt a newbie stall...it feels like the rpms suddenly drop.
this has happened 4x in about 4k miles...rare, but has happened at very inopportune times
has anyone else experienced this?
any fix?
Many people buy the BoosterPlug to fix this issue. Low rpm stalls aren't common but aren't unheard of either. By very "inopportune times", are you referring to resting at a stop light while trying to make eye contact with a blonde 20-something standing on the sidewalk? All joking aside, the best way to fix this without modifying anything is simply twisting more throttle out of her.

Your dealer might be able to adjust your idle speed and increase fuel ratio as another viable solution.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
thanks so much
i will consider that
stall is perhaps the wrong word...the engine cuts out
i did find a thread in the forum regarding this though
Triumph Bobber Forum > Triumph Bobber Issues, Problems, Defects and Recalls > Triumph Bobber Issues And Problems > The engine goes off
 

·
Registered
Joined
·
602 Posts
Happened to a few other and myself, however in those cases it was pre 1st service, no issues since the service for me at all
 

·
Registered
Joined
·
505 Posts
Make sure your ‘17 bobber has the latest tune supplied by triumph. I have heard this complaint before but it hasn’t been for quite some time. It could very well be an issue on earlier bikes that was resolved with an updated map.
 

·
Registered
Joined
·
66 Posts
This also happened to me.......typically I would be slowing down and down-shifitng.....when I would pull in my clutch lever the engine would just stop. Typically I would shift up a gear ......engage the clutch and start the engine on a roll.

I took it to Triumph and they reflashed/remapped the ECU and I haven't had the problem since.
 
1 - 9 of 9 Posts
Top