Triumph Bobber Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
62 Posts
Discussion Starter #1
I recently installed new Wilber’s shock on my ride. I took it out on a quick test ride to make sure everything was functioning properly. I pulled off the road to do a quick visual inspection. straight away I noticed that the right side cover was not properly attached. headed home after sorting it and completing the inspection. When I arrived a my house I noticed the left side cover was now missing. Retraced my rout and found it just on the road shoulder. What I think happened is that the grommet in the frame must have come loose at some point and the entire panel flew off of the bike. I didn’t notice this until after I received the replacement off of Ebay. I probably caused the entire issue and thought it wise to post as a warning to be more observant and detail oriented than I was.
 

Attachments

·
Registered
Joined
·
171 Posts
No big..could have been worse.. YOU could have been found on the road shoulder..
I don’t math good either...
 

·
Super Moderator
Joined
·
3,352 Posts
Glad it’s only plastic and not something more serious.
On a more positive note, how are you liking the Wilber shock?
 

·
Registered
Joined
·
675 Posts
Don’t beat yourself up. I set off on a recent test ride after modding my rear plate and lights, to be greeted by a disturbing noise from the rear. I had removed the bolts that support the rear fender and left them on the bench in the workshop.


Many years ago they used to let me help build aircraft ?
 
1 - 7 of 7 Posts
Top