Triumph Bobber Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
Hi, any one installed the Triumph Bobber Wunderkind CNC Milled Upper Fork Covers with the led indicators, I was set to have my local dealer do the install but they have sold up and been taken over, they now only do genuine triumph part installs!

So I have the parts, instructions are in German, any help or advice from anyone who has installed them pls?
No idea where to start...
 

Attachments

·
Super Moderator
Joined
·
3,352 Posts
This might help with the general install (the principle is the same)

https://cdn.freespiritsparts.com/media/catalog/product/3/0/302319_-_21_multi_sp_2.pdf

You will have to cut and splice the indicator cable which is very easy and no resistors are needed. You may have to choose a different flash rate/sequence which can be done via the speedo & buttons. The instructions for this are in the Bobber owners manual.

Here is my thread:
https://www.triumphbobberforum.com/forum/601-what-did-you-do-your-triumph-bonneville-bobber-today/7786-wunderkind-accessory-install.html
 

·
Registered
Joined
·
366 Posts
You may have to choose a different flash rate/sequence which can be done via the speedo & buttons. The instructions for this are in the Bobber owners manual.


Huh you learn something new every day .
 

·
Registered
Joined
·
228 Posts
I set the flash rate #1 after installing the same kit. They flash faster than usual but it’s the only setting that worked so the hazard lights worked as well. There’s no way to get the signals working at normal speed and having hazard lights. I don’t mind the faster signal rate in order to have hazard lights. I’ve tried every possible sequence with and without resistors. I’ve installed the kit on 3 BB so far. Hope this is the answer you need
 

·
Registered
Joined
·
59 Posts
Hi, any one installed the Triumph Bobber Wunderkind CNC Milled Upper Fork Covers with the led indicators, I was set to have my local dealer do the install but they have sold up and been taken over, they now only do genuine triumph part installs!



So I have the parts, instructions are in German, any help or advice from anyone who has installed them pls?

No idea where to start...
Curious, did you ever figure this out and get them installed? If you did, pics?

Sent from my ONEPLUS A5010 using Tapatalk
 

·
Registered
Joined
·
31 Posts
Discussion Starter #7
Curious, did you ever figure this out and get them installed?
No not done it yet, Eisen77 provided me everything needed in the links above, but I am just worried about taking snippers to my wiring just as the warm riding weather is arriving. Chicken, yes, guilty as charged... lol
 
1 - 7 of 7 Posts
Top