Triumph Bobber Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter #1
Managed to get the initial miles within 7 days so first service could be done. :smile2:

Dealer performed first service, but also had to also do "Throttle Body Balance" under Warranty. Apparently when they ran a scan it showed up and required some work to be able to clear the code. they indicated that the bike was not idling correctly.

There wasn't anything that I noticed during first week that would indicate an issue.

Anyone else experience any throttle issues or have to have this performed also?
 

·
Registered
Joined
·
4 Posts
Managed to get the initial miles within 7 days so first service could be done.


Dealer performed first service, but also had to also do "Throttle Body Balance" under Warranty. Apparently when they ran a scan it showed up and required some work to be able to clear the code. they indicated that the bike was not idling correctly.

There wasn't anything that I noticed during first week that would indicate an issue.

Anyone else experience any throttle issues or have to have this performed also?
Yes I had an issue getting ready for first service and advised that it jerks to much at lower speeds also it has turned off when coming to a stop they t
Said the throttle bodies were way put of balance and adjusted it. Was much better riding after adjustment but said it was very rare for thus to happen
 

·
Registered
Joined
·
16 Posts
I've only had my Bobber a couple of weeks and from the off had issues with the throttle.

Found that mine was not dropping the revs and dragging me into corners and so on. It's in now having a new throttle body.
 
1 - 3 of 3 Posts
Top