Triumph Bobber Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter · #1 · (Edited)
Does anyone know the process of how to contact Triumph regarding an issue with my Bobber that is a warranty issue???

As many here have noted, I am also having an issue with significant chaffing of the clutch cable where it passes through the metal loop guide that is mounted in the front fork area. I was in today for my first 500 mile service and pointed it out to the technician. He made a note and said it is in the hands of Triumph to follow up. I'm not comfortable with that answer and wish to pursue a remedy with Triumph myself.

Any help from those that have gone to Triumph themselves is greatly appreciated.
 

·
Registered
Joined
·
360 Posts
I think that little clamp thingy has no real reason to be there, although some technical designer at Triumph decided otherwise; the cable has enough support, and is more free to move, (and looks better) without it in my opinion.
I've removed mine.

:surprise::surprise::surprise: oh no, I've probably just trashed my warranty!!:laugh:

This is of course up to the individual...(disclaimer) :wink2:

mike
 

·
Registered
Joined
·
140 Posts
My dealer replaced mine no questions asked, and fixed it so no more chance of chafing. Yours should, as well. This is not a "wear" item like brake pads, it's poor design, plain and simple. Good luck.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top