Triumph Bobber Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Bought a set of forward controls off of a Speedmaster from a forum member. Just finished installing them on my 2019 Bobber Black. Everything fit just fine and it looks awesome. So my problem is now my brake light stays on and my ABS light is blinking. I’m assuming because something isn’t adjusted right, my brake light is stuck on which is messing with the ABS sensor. I can put parts on, but the tech stuff I’m oblivious to. Any help would be very much appreciated!! Thanks!


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
18 Posts
Discussion Starter #3
Thanks a million. I’ll see what we may have done wrong. No instructions. I bought the parts used and installed. Didn’t think it would be a big deal. Always seems like it’s something stupid. Thank you again!!


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
85 Posts
Hey JP sorry to hear about the brake issues you’re running into. I wish I could help. I know there is a lot of smart people on here that can help. Hope you get the problem resolved quickly.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #5
Got it! Thanks for the concern, fatty. It was the brake light switch that wasn’t seated right. I knew it was something small. The forward controls are awesome. Exactly what I was looking for. Thank you eisen for the instructions. We were able to trace the problem.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
816 Posts
Sounds like maybe when you swapped the bracket for the master cylinder mount, you might have forgotten to adjust the micro-switch for the brake light, when you rotate the shaft that connects to the brake pedal linkage, you should here the switch click just as it starts to rotate when you press on the brake, or just before it it stops rotating and the pedal comes to the rest position.

Not sure if this vid will help but, I couldn't figure out how to describe it better :grin2:

Might want to turn up your sound, its not very loud


If you can't hear it clicking, then that's probably the issue, you will need to do a bit of disassembly again to get to where you can adjust the switch.

Hope this helps!

Good Luck.
 
1 - 8 of 8 Posts
Top