Triumph Bobber Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
15 Posts
The ABS light should be blinking when you first start the bike, indicating that the system is functioning properly. However, it should also extinguish after either a certain distance is traveled (a couple feet/yards maybe) or a certain speed is reached (~5-10 mph). The dealer told me which one I just can't remember presently.
If your ABS light illuminates DURING your ride, that would indicate a malfunction of the ABS and should be looked at by dealer. The brake system will still function properly with the ABS inoperative. I wouldn't worry about it too much between now and your service time Saturday. But definitely mention it to the dealer.
 

·
Premium Member
Joined
·
1,689 Posts
Discussion Starter #4
Thanks for he response. I have called the dealer and told them. They have made a note to check it at the 500 mile service on Sat.
 

·
Premium Member
Joined
·
1,689 Posts
Discussion Starter #5
It should cease blinking at 6 mph.
I missed this while responded to the other post. I'll check this out, but seemed like the light remained blinking for the whole 20min ride.

I'll double check, could be wrong.

Was that info you ascertained from riding or was that from another source?
 

·
Registered
Joined
·
792 Posts
I missed this while responded to the other post. I'll check this out, but seemed like the light remained blinking for the whole 20min ride.

I'll double check, could be wrong.

Was that info you ascertained from riding or was that from another source?
That is from the owners manual and riding!
 

·
Premium Member
Joined
·
1,689 Posts
Discussion Starter #7
Nice! And I read that thing front to back....;)

So blinked a little past 6mph, gave the breaks a bit of a work out and the light went off. Something lodged or a fluke. Thanks for the help!
 
1 - 7 of 7 Posts
Top