Thin chrome. - Triumph Bobber Forum
 6Likes
Reply
 
LinkBack Thread Tools
post #1 of 12 (permalink) Old 02-18-2019, 07:07 AM Thread Starter
Junior Member
 
Join Date: Jun 2018
Location: Gold Coast Australia
Posts: 20
Thin chrome.

A few parts of my bike are showing signs of corrosion and is less than 12 months out of the show room. Most notably spokes on the leading edge for now. As well the large torx bolt heads on shock and seat and a few other places. I look after my bike wash it every two weeks and do the MR Sheen clean before every ride, so there is no shortage of TLC. I am off to the dealer, Oliver's Brisbane, tomorrow to submit a warranty claim . They will take pics and send a warranty request to Triumph Australia. It would be interesting to hear others are faring esp those in places that have icy roads where salt is used. Look forward to hearing from others.
Skins is offline  
post #2 of 12 (permalink) Old 02-18-2019, 07:27 AM
Member
 
Tomsy's Avatar
 
Join Date: Jul 2018
Posts: 62
I thought it was just me not cleaning enough, I mean I clean weekly and I try not to ride in the wet but the roads are usually damp first thing in the morning. I have slight rust spots on my spokes too and also on the top half of the front shocks!!
Skins likes this.
Tomsy is offline  
post #3 of 12 (permalink) Old 02-18-2019, 09:18 AM
Member
 
Edwoodcostin's Avatar
 
Join Date: Aug 2018
Posts: 43
As well as the indicators being replaced twice within 6 months....my spokes, tyre valves seat pan and forks all have rust/surface corrosion on them despite many applications of acf50 and other protective products. Won't ask dealer until spring but I think the bike just isn't up to bad weather riding. Poor quality bits etc. Almost forgot...the cam cover has been replaced too due to bubbling under the paint. Pretty shoddy
Skins likes this.
Edwoodcostin is online now  
Sponsored Links
Advertisement
 
post #4 of 12 (permalink) Old 02-18-2019, 09:20 AM
Senior Member
 
Mike J Commo's Avatar
 
Join Date: Mar 2018
Location: The Garden Of England, Kent
Posts: 1,146
Garage
Cleaning alone isnít enough Iím afraid chaps... you need to be using something like ACF-50 or equivalent to prevent the onset of corrosion.

Washing the bike will of course remove contaminants, salt bring the worst... but ultimately you are still applying water to an untreated metal surface and that in itself is enough to cause the issues youíre experiencing.
Bobber-Bomb and ysoslo like this.
Mike J Commo is offline  
post #5 of 12 (permalink) Old 02-20-2019, 08:45 PM Thread Starter
Junior Member
 
Join Date: Jun 2018
Location: Gold Coast Australia
Posts: 20
Thanks for the replies guys. I've had one or two bikes in my time albeit Italian and Japanese. This is my first Triumph. I can't remember any that have been affected so quickly by corrosion. I understand the whole manufacturing assembly process and know that a batch of inferior quality parts may have eluded the quality control. My dealer sent photos and supporting email to Triumph Australia yesterday even stating how well looked after the bike appeared to them. They flatly rejected any warranty claim stating neglect. Not happy Mr Triumph Australia. My next course of action is to make personally contact with all details. I will let you know of any outcome. Cheers
Skins is offline  
post #6 of 12 (permalink) Old 02-20-2019, 08:52 PM Thread Starter
Junior Member
 
Join Date: Jun 2018
Location: Gold Coast Australia
Posts: 20
Quote:
Originally Posted by Mike J Commo View Post
Cleaning alone isnít enough Iím afraid chaps... you need to be using something like ACF-50 or equivalent to prevent the onset of corrosion.

Washing the bike will of course remove contaminants, salt bring the worst... but ultimately you are still applying water to an untreated metal surface and that in itself is enough to cause the issues youíre experiencing.
Gday Mike. I hear what you're saying but the corrosion should not have started in the parent metal if the chrome work was adequate. I've had 15yo dirt bikes with spoke wheels that were in better condition and they were only ever washed with a garden hose on jet spray.
Skins is offline  
post #7 of 12 (permalink) Old 02-21-2019, 03:12 AM
Member
 
Join Date: Jun 2018
Posts: 78
I suspect some of your cleaining/protective fluid will cause it.
I ride in rain, we have also 6 month winter(snow period) when bike sitting in high hummidity garage.

I use "Motul E2 moto wash" after week(if got some rain) or two and once per month tar/road dirt remover(will wash it off with Motul).
No other cleaning or protective fluids,
I have no rust.

Also chrome parts you name are from different manufacturer, i doubt that they all have so bad quality.
Also isnt hex polts stainless steel and not chromed ?
ivx675 is online now  
post #8 of 12 (permalink) Old 02-21-2019, 06:11 AM
Member
 
Edwoodcostin's Avatar
 
Join Date: Aug 2018
Posts: 43
Suggesting neglect and not cleaning enough sounds like such a cop out from people owning and selling very expensive products that should be usable all year round in all weather conditions. See attached pic of the seat pan which is also now corroded underneath the paint. Are you seriously suggesting this is through lack of cleaning?!
Attached Thumbnails
Click image for larger version

Name:	IMG_20190219_171455_1550747478519.jpg
Views:	89
Size:	71.0 KB
ID:	30997  
Skins likes this.
Edwoodcostin is online now  
post #9 of 12 (permalink) Old 02-21-2019, 08:06 AM
Senior Member
 
Bob's_yer_firkin's Avatar
 
Join Date: Jul 2017
Location: Kent, England
Posts: 259
I have to agree, my bike isn't used in the rain or in the winter where the roads are salted and its garaged yet it still has some trace rust on the spokes. Years ago I had a 650 Triumph and had the wheels rebuilt with alloy rims and stainless steel spokes so it can be done.
Bob's_yer_firkin is offline  
post #10 of 12 (permalink) Old 02-21-2019, 08:16 AM
Member
 
Join Date: Jun 2018
Posts: 78
Just went to garage looked over, no rust on spokes,brake discs,bolts,only chain has a little. I bought mine in 15 may 2018, probably too new.
Bike is sitting in garage sine 28 october, snow came down.
I use only cheap Motul moto E2 wash and no protective fluids, works ok for me.

Time will tell if rust will appear,
ivx675 is online now  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
UK/EU indicators > US LED ones - Removal of chrome DeeEff Appearance Modifications 5 07-15-2018 08:37 AM
Brand New Chrome Sprocket Freedom40 Triumph Bobber Parts 2 05-18-2018 08:50 PM
Morello Red + Chrome high bars? johncessna Triumph Bobber Forum General Discussion 3 04-29-2018 01:09 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome