Brake Light and ABS Light - Triumph Bobber Forum
 5Likes
  • 1 Post By PJStock
  • 2 Post By PJStock
  • 1 Post By Great Black North
  • 1 Post By Great Black North
 
LinkBack Thread Tools
post #1 of 8 (permalink) Old 08-10-2019, 06:35 PM Thread Starter
Junior Member
 
PJStock's Avatar
 
Join Date: Jun 2019
Location: Maine
Posts: 10
Brake Light and ABS Light

Bought a set of forward controls off of a Speedmaster from a forum member. Just finished installing them on my 2019 Bobber Black. Everything fit just fine and it looks awesome. So my problem is now my brake light stays on and my ABS light is blinking. Iím assuming because something isnít adjusted right, my brake light is stuck on which is messing with the ABS sensor. I can put parts on, but the tech stuff Iím oblivious to. Any help would be very much appreciated!! Thanks!


Sent from my iPad using Tapatalk
PJStock is online now  
post #2 of 8 (permalink) Old 08-10-2019, 06:41 PM
Super Moderator
 
eisen77's Avatar
 
Join Date: Feb 2017
Location: Palma de Mallorca
Posts: 3,074
Do you have the instruction manual?
I can’t help with the errors, but here are the links to the manuals and perhaps you can trace your steps to see that everything was installed correctly?

https://www.triumphinstructions.com/...9770179-EN.pdf

https://www.triumphinstructions.com/...9770115-EN.pdf

Last edited by eisen77; 08-10-2019 at 06:45 PM.
eisen77 is online now  
post #3 of 8 (permalink) Old 08-10-2019, 06:43 PM Thread Starter
Junior Member
 
PJStock's Avatar
 
Join Date: Jun 2019
Location: Maine
Posts: 10
Thanks a million. Iíll see what we may have done wrong. No instructions. I bought the parts used and installed. Didnít think it would be a big deal. Always seems like itís something stupid. Thank you again!!


Sent from my iPad using Tapatalk
eisen77 likes this.
PJStock is online now  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 08-10-2019, 08:56 PM
Member
 
fatty0100's Avatar
 
Join Date: Feb 2019
Location: Los Angeles, CA
Posts: 46
Hey JP sorry to hear about the brake issues you’re running into. I wish I could help. I know there is a lot of smart people on here that can help. Hope you get the problem resolved quickly.
fatty0100 is offline  
post #5 of 8 (permalink) Old 08-10-2019, 10:44 PM Thread Starter
Junior Member
 
PJStock's Avatar
 
Join Date: Jun 2019
Location: Maine
Posts: 10
Got it! Thanks for the concern, fatty. It was the brake light switch that wasnít seated right. I knew it was something small. The forward controls are awesome. Exactly what I was looking for. Thank you eisen for the instructions. We were able to trace the problem.


Sent from my iPad using Tapatalk
eisen77 and ysoslo like this.
PJStock is online now  
post #6 of 8 (permalink) Old 08-10-2019, 10:58 PM
Senior Member
 
Great Black North's Avatar
 
Join Date: Aug 2017
Location: Northern Alberta
Posts: 357
Garage
Sounds like maybe when you swapped the bracket for the master cylinder mount, you might have forgotten to adjust the micro-switch for the brake light, when you rotate the shaft that connects to the brake pedal linkage, you should here the switch click just as it starts to rotate when you press on the brake, or just before it it stops rotating and the pedal comes to the rest position.

Not sure if this vid will help but, I couldn't figure out how to describe it better

Might want to turn up your sound, its not very loud


If you can't hear it clicking, then that's probably the issue, you will need to do a bit of disassembly again to get to where you can adjust the switch.

Hope this helps!

Good Luck.
eisen77 likes this.

My Bike's Photographic History to Date
Yes I'm Proud of My Bike! Deal!
Great Black North is offline  
post #7 of 8 (permalink) Old 08-10-2019, 11:00 PM
Senior Member
 
Great Black North's Avatar
 
Join Date: Aug 2017
Location: Northern Alberta
Posts: 357
Garage
LOL well ... Glad you figured it out!
eisen77 likes this.

My Bike's Photographic History to Date
Yes I'm Proud of My Bike! Deal!
Great Black North is offline  
post #8 of 8 (permalink) Old 08-11-2019, 12:34 PM
Member
 
fatty0100's Avatar
 
Join Date: Feb 2019
Location: Los Angeles, CA
Posts: 46
Awesome !
fatty0100 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome